#37 Building Lighting in UE4 | LIGHTING NEEDS TO BE REBUILT fix for Unreal Engine 4

コメント数

  1. Ahmad Hussian

    Ahmad Hussianヶ月 前

    FINALLY, thank you for showing how to solve that compiling issue, since you (and I) painted the landscape the first time some of the shadders did not compile and it drove me crazy. You will never imagine how relieved I am right now.

  2. Gregg Everman

    Gregg Everman2 ヶ月 前

    The vid seems to just stop loading after a certain amount of time. Just to let ya know.

  3. Sazie 139

    Sazie 1392 ヶ月 前

    I cant get the build lighting to go past 0% can anyone help?

  4. i dont care

    i dont care9 日 前

    me neither. foliage takes forever for the build lighting.

  5. Gamer Max

    Gamer Max3 ヶ月 前

    I can hear the fan noise

  6. Gamer Max

    Gamer Max3 ヶ月 前

    Me too when i am using UE4 i also hear from my laptop.

  7. Game Dev Academy

    Game Dev Academy3 ヶ月 前

    Yep. The laptop really wasn't built for this.

  8. Klabauter Mann

    Klabauter Mann5 ヶ月 前

    0:25 ( ͡ʘ ͜ʖ ͡ʘ)

  9. J A

    J A6 ヶ月 前

    I'm having all kinds of problems with building lighting. First time I tried I just kept crashing after 4 hours. I reduced the amount of objects, and got thru a lighting rebuild, but then shadows were spread around willy nilly and not corresponding at all to a light source and I've had some foliage that just turned black. I turned off Cast static shadow and turned on cast dynamic shadow in the foliage tab in instance settings. I had the light rebuild do everything it was supposed to this time around with meshes I placed, but any foliage had no shadows at all. Everything is washed out, and there's hardly any difference with the shadows that do show up. I don't know if I missed a step, or what...but before the lighting build, everything on my map looked really good...then I rebuild the lighting and everything looks like absolute dump.

  10. Nade Swiiv

    Nade Swiiv8 ヶ月 前

    Hello, everything looked fine until I build the lightning (BEFORE Build: prntscr.com/mcow51 //// AFTER Build: prntscr.com/mcovp5) Do you have any idea what the issue could be? (I don't have normal maps / roughess maps for some of my textures if that might be an issue)

  11. murnavid

    murnavid7 ヶ月 前

    the textures might not be bright enough for the lights. also i found that not using static light and object dont need to be rebuilt. do the world setting option and also add a skylight if not present also after build it looks better

  12. Me Ka

    Me Ka年 前

    Hello :) Does anybody know why the landscape in my level loses their textures when building lighting?

  13. Me Ka

    Me Ka年 前

    The Material is back :D Thx :) And thank you so much for the tutorials!

  14. Game Dev Academy

    Game Dev Academy年 前

    Yes. Watch this video to the end - I show you how to fix it.

  15. Anthony Rivera

    Anthony Rivera年 前

    say you have 3 levels streamed next to each other, cant bake them all at once so instead i bake them 2 at a time towards the light source so overlapping shadows are baked in, but even after that it says i still need to bake lighting even tho its all fine... and on top of that when all 3 are loaded in it adds this horrible added light into it all, screwing with all the bakes as if i added another light source and havent baked them. is there a way to fix this?

  16. Clara Hickox

    Clara Hickox年 前

    hello, I have an issue building my lighting. I followed the instructions exactly, but my shadows are barely visible, and not black at all like yours are. The environment color doesn't make a difference, it's always is the same color; a barely visible grey. can you help me?

  17. Murtaza Rizvi

    Murtaza Rizvi7 ヶ月 前

    ​@Roby Coltan light building is pretty tricky. light always builds on static mesh and not on stationary mesh regardless of light. i had a scene with no static mesh but various static light and no building msg.

  18. Roby Coltan

    Roby Coltan年 前

    Same problem here.... and I turned off the auto exposure and nothing changed... XD

  19. Game Dev Academy

    Game Dev Academy年 前

    I have auto exposure turned off on mine - that might be the difference.

  20. Raphael Attar

    Raphael Attar年 前

    My build was taking more than 30 minutes with a good gaming laptop. I read online that you can change the foliage settings from static to movable to help make it faster. It made a big difference but the shadows looked horrible. Is there anything I should take a look at or change so that this doesn't take hours to build?

  21. Raphael Attar

    Raphael Attar年 前

    thanks for the reply! I'll give it a shot

  22. Game Dev Academy

    Game Dev Academy年 前

    You could try adding a lightmass importance volume (google it)

  23. wasabifo

    wasabifo年 前

    Building lighting is stuck at 3% for me, please help

  24. Michael Charitou

    Michael Charitou10 ヶ月 前

    Same problem, checking the swarm agent tells me that it's just taking an absurdly long time to process mappings. Not sure how to speed it up

  25. curtinparloe

    curtinparloe年 前

    I fixed that by renaming the Save folder inside the project.

  26. Patrisiogames

    Patrisiogames年 前

    I have that problem, too.

  27. Amil Aliyev

    Amil Aliyev年 前

    Have the same problem....

  28. technology in

    technology in年 前

    thx alot i'm waiting for the next serie of video :D

  29. khayyam Al

    khayyam Al年 前

    And BTW how did you add multiple material in your landscape its seems you also paint some sections how did you do that?

  30. khayyam Al

    khayyam Al年 前

    OnlineMediaTutor | Maya modeling & animation tutorials! You are awesome man thank you

  31. Game Dev Academy

    Game Dev Academy年 前

    It's a tutorial series. Watch the other steps :)

  32. khayyam Al

    khayyam Al年 前

    Can you make Binoculars zoom Like ive got the asset but i dont know how to make my character use it (like by pressing e button) so it will zoom in